Discussion about CustomBuild

mcdcompanies

New member
Joined
Oct 5, 2007
Messages
3
I just ran this:
Code:
.build php n
and I get this error:
Code:
configure: error: Please reinstall the iconv library.

*** There was an error while trying to configure php. Check the configure/ap2/configure.php5 file
Now when apache tries to start I get this error:
Code:
Restarting apache.
Stopping httpd:                                            [  OK  ]
Starting httpd: httpd: Syntax error on line 17 of /etc/httpd/conf/httpd.conf: Syntax error on line 1 of /etc/httpd/conf/extra/httpd-phpmodules.conf: Cannot load /usr/lib/apache/libphp5.so into server: /usr/lib/apache/libphp5.so: cannot open shared object file: No such file or directory
Any help will be greatly appreciated. Thanks.
 

scsi

Verified User
Joined
Aug 19, 2008
Messages
4,695
Please reinstall the iconv library.

yum install iconv
apt-get install iconv

:D
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,935
Location
LT, EU
Try:
Code:
cd /usr/local/directadmin/custombuild
./build update
./build iconv
./build php n
 

aED

Verified User
Joined
Dec 20, 2009
Messages
42
I am running custombuild for the first time and then when it went to the point where it shows you where php.ini is and tells you to press the return key to continue I wasnt there when that happened and when I returned I saw that I need to press the return key but my SSH connection was already disconnected because of inactivity. What should I do after that should I execute ./build all d again?

and Is it ok te execute ./build all d over and over again?
 

frankc420

Verified User
Joined
Jul 31, 2007
Messages
55
I've been running the latest version of Zend for awhile now but Custombuild keeps telling me I need to run 3.3.3 (if I'm not mistaken), I'm .1 up on it, any reason this is not showing the latest zend versiON?
 

Mr. Jinx

Verified User
Joined
May 5, 2006
Messages
55
I'm getting the following error while trying to build PHP, how can i fix this
Have looked on Google and here in the forums, but can't find a solution. Thanks for your help!
I'm getting the same error (on Centos x64) when I try to build PHP with './build php y':
Code:
Installing PEAR environment:      /usr/local/lib/php/

Fatal error: Class 'PEAR' not found in phar://install-pear-nozlib.phar/index.php on line 24
make[1]: *** [install-pear-installer] Error 255
make: *** [install-pear] Error 2
Anyone knows what this means?

SOLVED:
I've excluded the APC extension in php.ini and now it compiles fine.
 
Last edited:

enginaar

Verified User
Joined
May 20, 2004
Messages
156
Location
Turkiye
Why has proftpd been set as "no". I did the first installation by custombuild and proftpd exists in the system. I want to run an update for everything, does this mean proftpd won't be updated.
 

postzegel

New member
Joined
Nov 12, 2008
Messages
6
Error after runing ./build php d:
checking for T1lib support... no
checking whether to enable truetype string function in GD... yes
checking whether to enable JIS-mapped Japanese font support in GD... no
checking for fabsf... yes
checking for floorf... yes
configure: error: libjpeg.(a|so) not found.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,935
Location
LT, EU
enginaar, yes. Just run "./build set proftpd yes" if you want it to be set to "yes".

postzegel, try:
Code:
cd /usr/local/directadmin/custombuild
./build update
./build libjpeg
./build php n
 

jissh

Verified User
Joined
Nov 27, 2004
Messages
154
Location
Winnipeg, Canada
I've searched the forums but can not find any real information on how to install MySQLi in PHP with custom build. I've confirmed --with-mysqli \ is in the configure.php5 file but yet it's no being added to the php.ini.

Any ideas?
 

mmgenius

Verified User
Joined
Jan 20, 2004
Messages
122
Is there an option to install/update exim using custombuild 1.1? Or is it only possible with 1.2?
 

tdldp

Verified User
Joined
May 9, 2005
Messages
169
Nothing special to know :) I've just edited my 1st post.
Sorry to unbury this...

I'd just passed aprox 2 hours in trying to gather all information in more than 30 threads, regarding custombuild...
I would believe, it would be kind of you if you could give more detailed information in that FAQ regarding :

Installation Process : What do each choice have as incidence...
Build commands : What is the exact list... What does each command... (i have found in latest version, lots of undocumented functions i don't know what they do on the system...)
Customisation options : What can be done, how, what is the interest...

In a second post in that locked FAQ, i think it would be great to update/restate, all pratical cases, that could need a manual correction, or a admin action, in order to set things up correctly...

I do think it would make custombuild more appreciable...

Yours

Tdldp
 

nobaloney

NoBaloney Internet Svcs - In Memoriam †
Joined
Jun 16, 2003
Messages
26,119
Location
California
I think I'm going to agree with this. Even with all the experience I have, I still find myself, sometimes, wondering about options.

I'd love to see a completely updated documentation set.

As soon as I'm finished with SpamBlocker Version 3 (almost done) I'm going to work on setting up my wiki.

Jeff
 

tdldp

Verified User
Joined
May 9, 2005
Messages
169
I think I'm going to agree with this. Even with all the experience I have, I still find myself, sometimes, wondering about options.

I'd love to see a completely updated documentation set.

As soon as I'm finished with SpamBlocker Version 3 (almost done) I'm going to work on setting up my wiki.

Jeff
Lol Jeff, great ideas meet themselves sometime...

Without going to setting up a personnal Wiki... I'd think it would be necessary to have a reserved access topic, between Martynas, DA staff, and those wishing to collaborate to setting up an up-to-date documentation on this custombuild...

It could help starting to update that locked FAQ topic, that is outdated..

Tdldp
 

webbird

New member
Joined
May 26, 2008
Messages
1
Hello,

I have a problem installing mod_cache with custom build.
I've tried all steps from this guide
http://help.directadmin.com/item.php?id=191

No errors with
./build clean
./build apache

My configure.apache is ok with these lines
"--enable-cache" \
"--enable-mem-cache" \
"--enable-disk-cache" \
"--enable-file-cache"

I've added mod_cache in httpd.conf

But after all I can't locate mod_cache in /usr/lib/apache
:confused:
 

emmanuel

Verified User
Joined
Mar 26, 2007
Messages
92
Option to stop custombuild from rewriting conf?

I just used custombuild to update apache using ./build apache
It broke one of my client WordpressMU site that was setup since the last update.

Apparently custombuild rewrites all the user httpd.conf file including the wildcard inserted into the virtualhost containers to enable subdomains without having to manually create every single one. Wordpress uses a .htaccess file to pass non-existent subdomains to index.php to handle.

I was going to update exim next but this got me worried that updating exim might break some options or another.

So is there a way to tell custombuild to just build the app and don't touch the conf files? I had looked inside options.conf but don't see anything like that.
 

cpisuisse

Verified User
Joined
Jan 19, 2007
Messages
11
Location
Netherlands
Pear HTML_Template_IT

Our client asked us to install pear HTML_Template_IT.
I am wondering whether the procedure should be:

# pear install HTML_Template_IT

And then ./build php n

Or is there a way to do this with custombuild entirely.

Server is Centos 5 64Bit
 
Top