Guide for installing Mailman with DirectAdmin

scsi

Verified User
Joined
Aug 19, 2008
Messages
4,695
Peter just run this:

/usr/local/mailman/bin/fix_perms -f
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,331
Location
LT, EU
If you won't be able to solve the problem- feel free to contact me, I'll take a look at it for free, but fix_perms script from /usr/local/mailman/bin should solve it.
 

Peter Laws

Verified User
Joined
Sep 13, 2008
Messages
1,747
Location
London UK
when the ./configure --with-guid- blah is given
--snip--
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking whether #! works in shell scripts... yes
checking for --with-var-prefix... no
checking for --with-permcheck... yes
checking for --with-username... mailman
checking for user name "mailman"... okay
checking for --with-groupname... mailman
checking for group name "mailman"... okay
checking permissions on /usr/local/mailman... configure: error:
***** Installation directory /usr/local/mailman is not configured properly!
***** Permissions should be at least 02775: /usr/local/mailman
 

scsi

Verified User
Joined
Aug 19, 2008
Messages
4,695
chmod -R 02775 /usr/local/mailman
chown -R mailman:mailman /usr/local/mailman
 

Peter Laws

Verified User
Joined
Sep 13, 2008
Messages
1,747
Location
London UK
The example one was for Redhat, which spouts errors, am looking for one for Debian

i.e:
# /etc/init.d/mailman start
/etc/init.d/mailman: line 70: /etc/rc.d/init.d/functions: No such file or directory
 

scsi

Verified User
Joined
Aug 19, 2008
Messages
4,695
The one I gave you said it was for debian....

Check your install folder:

doc/mailman-install.txt

Maybe try:

cp scripts/mailman /etc/init.d/mailman

when in the install dir.
 

Peter Laws

Verified User
Joined
Sep 13, 2008
Messages
1,747
Location
London UK
One last thing.....
After editing the httpd.conf (and restarting apache) as per tlchost's post, I get a 403 forbidden page :confused:

Edit:
I'm getting somewhere.......slowly

Now I get a 500 Error Page when going to:

http :// mailman . xxxxx .co.uk/mailman/admin/mailman

Ideas?

Permissions are all ok now, but suexec kicks up a fuss :) error: directory is writable by others: (/usr/local/mailman/cgi-bin))....... Hmmmmmmm
 
Last edited:

Peter Laws

Verified User
Joined
Sep 13, 2008
Messages
1,747
Location
London UK
Still going 500 with the log now saying:
[2008-10-21 12:02:48]: info: (target/actual) uid: (mailman/mailman) gid: (mailman/mailman) cmd: admin
[2008-10-21 12:02:48]: error: target uid/gid (1007/116) mismatch with directory (0/116) or program (0/116)
I even did ./check_perms -f at first, but still kicks up a fuss lol

I can't win :rolleyes:


Note: the user:group on all dirs in mailman are root:mailman, is that right or should mailman own them outright?
 

Peter Laws

Verified User
Joined
Sep 13, 2008
Messages
1,747
Location
London UK
Still have problems.... think I'll give up... am wasting valuable time......

It looked so simple by the step-by-step guide.......
 

tlchost

Verified User
Joined
Apr 4, 2007
Messages
381
Done it:

So..... my question is, why is chk_perms -f setting everything to root:mailman :mad: :mad:
It might be better if you let smtalk look at your system....he was of great assistance to me when I set mailman up on mine.

Thom
 
Top