Guide for installing Mailman with DirectAdmin

scsi

Verified User
Joined
Aug 19, 2008
Messages
4,695
Done it:

So..... my question is, why is chk_perms -f setting everything to root:mailman :mad: :mad:
It will set it to whatever user you installed it as. But I think it should of defaulted to mailman:mailman

Maybe specify the user and group when installing with the ./configure command
 

vousys

Verified User
Joined
Oct 25, 2008
Messages
6
Error 500

Hi ! I've installed as you said but when i try to access the "admin interface" i've get an erro 500 Internal Server Error .

What could happen ? i made the step by step perfectly as you said in the first post.

Thanks guys
 

tlchost

Verified User
Joined
Apr 4, 2007
Messages
381
Password Reminder script

Has anyone that followed the howto for Mailman noticed that the monthly password reminders are not being sent out?

I can't figure out why...but mine never get generated.

thanks

Thom
 

scsi

Verified User
Joined
Aug 19, 2008
Messages
4,695
I dont think you set the crons then?

You should read the install text again under the crons section.

What does this output:

Code:
crontab -u mailman -l
If nothing then you need to do the following:

Code:
cd /path/to/MAILMAN-SOURCE-FOLDER
cd cron
crontab -u mailman crontab.in
 

tlchost

Verified User
Joined
Apr 4, 2007
Messages
381
I dont think you set the crons then?

You should read the install text again under the crons section.

Thanks..it was installed by someone else

What does this output:

Code:
crontab -u mailman -l
It showed nothing, so I followed your instrutctions....thanks!


Thom
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,335
Location
LT, EU
Read /etc/init.d/mailman:
Code:
# We used to install the mailman cron jobs when the mailman rpm was
# installed, irrespective of whether mailman was actually being
# run. Although the cron jobs didn't create any problems if someone
# wasn't running mailman some users complained about the cron log file
# filling up, resource usage, and power consumption since systems
# wouldn't really idle. It really only makes sense to run the mailman
# cron jobs if the mailman service is turned on and not just merely
# having the rpm installed. This init.d script is an obvious place to
# install or remove the cron jobs based on the service being enabled
# or not.

SRC_CRON_SCRIPT=$MAILMANHOME/cron/crontab.in
DST_CRON_SCRIPT=/etc/cron.d/mailman

function InstallCron()
{
    install -m644 -o root -g root $SRC_CRON_SCRIPT $DST_CRON_SCRIPT
}

function RemoveCron()
{
cat > $DST_CRON_SCRIPT <<EOF
# DO NOT EDIT THIS FILE!
#
# Contents of this file managed by /etc/init.d/mailman
# Master copy is /usr/local/mailman/cron/crontab.in
# Consult that file for documentation
EOF
}
 

Yoshua

Verified User
Joined
Apr 9, 2007
Messages
69
Location
Spain
Greetings to all,

First thank you Smtalk and others for this guide, hopefully not long before integration Mailman in DirectAdmin.

I have followed all the steps, I had problems but I could solve them by reading the other messages in this thread, but the last problem I've found I cant fix, I tried everything, my only hope is that one can help me with this problem:

[2009-02-16 00:58:34]: uid: (501/501) gid: (501/501) cmd: listinfo
[2009-02-16 00:58:34]: target uid/gid (501/501) mismatch with directory (514/514) or program (514/514)
Thank you very much
 
Last edited:

Yoshua

Verified User
Joined
Apr 9, 2007
Messages
69
Location
Spain
Greetings,

I tried another option, I renamed /usr/sbin/suexec to /usr/sbin/suexec.old and then restarted Apache not to use Suexec, now the problem I see is:

Mailman CGI error!!!
The Mailman CGI wrapper encountered a fatal error. This entry is being stored in your syslog:
Group mismatch error. Mailman expected the CGI
wrapper script to be executed as group "mailman", but
the system's web server executed the CGI script as
group "apache". Try tweaking the web server to run the
script as group "mailman", or re-run configure,
providing the command line option `--with-cgi-gid=apache'.
I believe that some step is not well done, but I have reviewed everything and I can not find where. (i have Redhat CentOS 5.0)

Thank
 

nealdxmhost

Verified User
Joined
Jan 1, 2009
Messages
234
Location
Los Angeles CA
Code:
useradd -c'GNU Mailman' -s /no/shell -d /no/home -g mailman mailman
When I run that command I get this:

Code:
useradd: invalid numeric argument 'mailman'
What gives?????
 

scsi

Verified User
Joined
Aug 19, 2008
Messages
4,695
-c must be for something else on your useradd command or something.

What do you get from output: useradd -h
 

nealdxmhost

Verified User
Joined
Jan 1, 2009
Messages
234
Location
Los Angeles CA
I get the following:

Code:
useradd -h
useradd: invalid option -- h
Usage: useradd [options] LOGIN

Options:
  -b, --base-dir BASE_DIR       base directory for the new user account
                                home directory
  -c, --comment COMMENT         set the GECOS field for the new user account
  -d, --home-dir HOME_DIR       home directory for the new user account
  -D, --defaults                print or save modified default useradd
                                configuration
  -e, --expiredate EXPIRE_DATE  set account expiration date to EXPIRE_DATE
  -f, --inactive INACTIVE       set password inactive after expiration
                                to INACTIVE
  -g, --gid GROUP               force use GROUP for the new user account
  -G, --groups GROUPS           list of supplementary groups for the new
                                user account
  -h, --help                    display this help message and exit
  -k, --skel SKEL_DIR           specify an alternative skel directory
  -K, --key KEY=VALUE           overrides /etc/login.defs defaults
  -m, --create-home             create home directory for the new user
                                account
  -l,                       do not add user to lastlog database file
  -M,                       do not create user's home directory(overrides /etc/login.defs)
  -r,                       create system account
  -o, --non-unique              allow create user with duplicate
                                (non-unique) UID
  -p, --password PASSWORD       use encrypted password for the new user
                                account
  -s, --shell SHELL             the login shell for the new user account
  -u, --uid UID                 force use the UID for the new user account
  -Z, --selinux-user SEUSER     use a specific SEUSER for the SELinux user mapping
 

scsi

Verified User
Joined
Aug 19, 2008
Messages
4,695
Weird its the same. Make sure you are using the right kind of quote ' not `. Or else you can use "
 

ardactn

Verified User
Joined
Mar 12, 2008
Messages
7
Greetings,

I tried another option, I renamed /usr/sbin/suexec to /usr/sbin/suexec.old and then restarted Apache not to use Suexec, now the problem I see is:



I believe that some step is not well done, but I have reviewed everything and I can not find where. (i have Redhat CentOS 5.0)

Thank
I have same problem too.
Did you solved that problem?
 
Top