Guide for installing Mailman with DirectAdmin

tlchost

Verified User
Joined
Apr 4, 2007
Messages
381
Is mailman a workable alternative on da?
Yes.....I run multiple lists on multiple domains with the configuration described in this thread.

I would hope it would become a choice in the Control Panel, rather than
having to set it up manually.

Thom
 

localhost

Verified User
Joined
Aug 17, 2007
Messages
164
Location
Moldova
On my CentOS box o got huge errors about mussing things and stuff, I never made it running.
 

nealdxmhost

Verified User
Joined
Jan 1, 2009
Messages
234
Location
Los Angeles CA
I have gotten most of the way with this install however I am getting the following errors;

Code:
/etc/init.d/mailman start
Starting mailman: Traceback (most recent call last):
  File "/usr/local/mailman/bin/mailmanctl", line 106, in ?
    from Mailman import mm_cfg
  File "/usr/local/mailman/Mailman/mm_cfg.py", line 53
    DEFAULT_EMAIL_HOST = 'dxmhosting.com'
    ^
SyntaxError: invalid syntax
Needless to say I have something configured wrong there but not exactly sure what it is

Second thing I am getting is this when I browse to http://dxmhosting.com/mailman
Code:
Mailman CGI error!!!
The Mailman CGI wrapper encountered a fatal error. This entry is being stored in your syslog:

Group mismatch error.  Mailman expected the CGI
wrapper script to be executed as group "mailman", but
the system's web server executed the CGI script as
group "admin".  Try tweaking the web server to run the
script as group "mailman", or re-run configure, 
providing the command line option `--with-cgi-gid=admin'.
 

nealdxmhost

Verified User
Joined
Jan 1, 2009
Messages
234
Location
Los Angeles CA
Something here that I am not quite grasping, basically what file should those entries be inserted into or do I need to create a new file for those entries and where do I install them?

Code:
test:              "|/usr/local/mailman/mail/mailman post test" 
test-admin:        "|/usr/local/mailman/mail/mailman admin test" 
test-bounces:      "|/usr/local/mailman/mail/mailman bounces test" 
test-confirm:      "|/usr/local/mailman/mail/mailman confirm test" 
test-join:         "|/usr/local/mailman/mail/mailman join test" 
test-leave:        "|/usr/local/mailman/mail/mailman leave test" 
test-owner:        "|/usr/local/mailman/mail/mailman owner test" 
test-request:      "|/usr/local/mailman/mail/mailman request test" 
test-subscribe:    "|/usr/local/mailman/mail/mailman subscribe test" 
test-unsubscribe:  "|/usr/local/mailman/mail/mailman unsubscribe test"
 

scsi

Verified User
Joined
Aug 19, 2008
Messages
4,695
They go in the alias file for the domain in /etc/virtual
 

framon

Verified User
Joined
Nov 14, 2010
Messages
12
Cannot configure httpd with mailman

Hi
I've tried to install mailman following the guide a coulpel of time but the main problem is the I cannot access the domain.com/mailman/ folder I got a 403 Error

the strange is that I can access :
domain.com/mailman_images/
domain.com/mailman/archives/

I've checked and fixed the file permission with the /usr/local/mailman/bin/check_perms and everithing is all right.

if I try to access the listinfo script I got the a 500 error and the following suexec log

uid: (501/admin) gid: (501/admin) cmd: listinfo
directory is writable by others: (/usr/local/mailman/cgi-bin)

I think it is a http configuration isse, but I cannot solve it
what can be the problem ???
 

framon

Verified User
Joined
Nov 14, 2010
Messages
12
well..... it turned out that for mailman with suexec that file permission should be different:

all mailman and cgi-in directory should be 755 so not writables for others
and the scripts inside cgi-bin shuld not have the setuid turned on


so
chmod 755 /usr/local/mailman/cgi-bin
chmod 755 /usr/local/mailman/cgi-bin/*
chmod a-s /usr/local/mailman/cgi-bin/*
 

chrisrandell

Verified User
Joined
Mar 14, 2007
Messages
24
What would it take to get some assistance setting this up? Feel free to PM me... im kinda frustrated


Code:
[root@207612 extra]# service mailman start
Starting mailman: Traceback (most recent call last):
  File "/usr/local/mailman/bin/mailmanctl", line 106, in ?
    from Mailman import mm_cfg
  File "/usr/local/mailman/Mailman/mm_cfg.py", line 54
    add_virtualhost(mailman.blitz-hosts.com, blitz-hosts.com)
    ^
SyntaxError: invalid syntax
Grumble Grumble...
 

scsi

Verified User
Joined
Aug 19, 2008
Messages
4,695
It tells you exactly whats wrong. You proabably didnt put single quotes around your hosts.
 

Yoshua

Verified User
Joined
Apr 9, 2007
Messages
69
Location
Spain
We still continue not to use Mailman with suexec enabled?

Today I re-read the four pages of this thread, I have returned to perform all the steps carefully, I looking for more information on Google and I always get the same error ...

500 Server error!

The server encountered an internal error and was unable to complete your request.

Error message:
Premature end of script headers: listinfo
suexec.log

Code:
[2012-06-11 20:46:27]: uid: (501/admin) gid: (502/admin) cmd: listinfo
[2012-06-11 20:46:27]: target uid/gid (501/502) mismatch with directory (492/492) or program (492/492)
CentOS 6.2

Thank
 

overmind

Verified User
Joined
Feb 1, 2008
Messages
12
I want to install MailMan on FreeBSD. I've noticed this tutorial is from 2008. I wonder how actual it is?
 

hangxanh

New member
Joined
Oct 23, 2014
Messages
4
Follow me, Weird its the same. Make sure you are using the right kind of quote ' not `. Or else you can use "
 

cocotte67

New member
Joined
Dec 8, 2014
Messages
3
Authenticaton issue

Hello everybody. I've been using DirectAdmin custombuild for years (since 2008 I believe), and I've learned a lot reading this forum over the years. But now I had to register because I'm running into an issue that I can't seem to find a solution to, so I decided to ask for your help:

I've installed Mailman (because of Majordomo's trouble with Yahoo's DMARC), following this guide, on my VPS running CentOS 6.6 and DA 1.46.3. I had to configure mailman without suexec, like Yoshua, excepted I had to indicate the user name that goes with my mailing lists' domain name instead of "apache".

The issue I'm having now is with authentication in Exim, not sure whether it's Mailman- or Exim-related: Whenever I send a message to one of my Mailman list, I get H=localhost (my_server's_rDNS_name) [::1] F=<list_name-bounces@list's_domain_name> rejected RCPT <list_member's_mail_address (not local)>: authentication required in my Exim logs. Only local list members get the messages.

The only workaround I found so far is adding list_name-bounces@list's_domain_name to Exim's whitelist_senders file (I'm using SpamBlocker 4.2.2 for exim.conf). But I feel this it not a secure way to go, because these whitelisted adresses can be spoofed, so I'd like to find the real cause and solution to this authentication issue. I'm certainly missing something in Exim's configuration, but I can't see what. Any ideas?

Thanks a lot in advance.
 

nobaloney

NoBaloney Internet Svcs - In Memoriam †
Joined
Jun 16, 2003
Messages
26,119
Location
California
You're right; that's not a good idea; workaround can open up a hole big enough to drive a truck full of spam through it.

Mailman is trying to relay, but it's not authenticating as a user.

That's all I can tell you because I'm not familiar ehough with Mailman. Hopefully someone else, who is, will also respond.

Jeff
 

twv

Verified User
Joined
Oct 31, 2003
Messages
175
I'm having the same issue. Did you ever find a better answer than whitelisting the list_name-bounces@example.com address?


Hello everybody. I've been using DirectAdmin custombuild for years (since 2008 I believe), and I've learned a lot reading this forum over the years. But now I had to register because I'm running into an issue that I can't seem to find a solution to, so I decided to ask for your help:

I've installed Mailman (because of Majordomo's trouble with Yahoo's DMARC), following this guide, on my VPS running CentOS 6.6 and DA 1.46.3. I had to configure mailman without suexec, like Yoshua, excepted I had to indicate the user name that goes with my mailing lists' domain name instead of "apache".

The issue I'm having now is with authentication in Exim, not sure whether it's Mailman- or Exim-related: Whenever I send a message to one of my Mailman list, I get H=localhost (my_server's_rDNS_name) [::1] F=<list_name-bounces@list's_domain_name> rejected RCPT <list_member's_mail_address (not local)>: authentication required in my Exim logs. Only local list members get the messages.

The only workaround I found so far is adding list_name-bounces@list's_domain_name to Exim's whitelist_senders file (I'm using SpamBlocker 4.2.2 for exim.conf). But I feel this it not a secure way to go, because these whitelisted adresses can be spoofed, so I'd like to find the real cause and solution to this authentication issue. I'm certainly missing something in Exim's configuration, but I can't see what. Any ideas?

Thanks a lot in advance.
 

dalem

Verified User
Joined
Jun 8, 2006
Messages
5
Old thread having the same issue
moved mailmain from centos5 which it worked just fine to centos7

could not get mailman to authenticate
 
Top